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 1. Introduction

PWMinder is a desktop application that is used to store and manage passwords and other sensitive data in a 
secure encrypted file.  This document explains how to install and use PWMinder 3.0.

 1.1. Conventions

The following conventions are used in this User Guide.

Commands, directory and file names are written in mono-spaced font.

Important: notes are written in bold.

Warning: notes are written in bold red.

Note: all Screen Shots in this Guide are taken using the “Nimbus” Look and Feel on Windows 7.
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 2. System Requirements

 2.1. Windows

Operating System: Windows XP, Windows Vista, Windows 7, Windows 8 and Windows 8.1

Free Disk Space: 5 - 50 MB

System Memory: 1GB or higher (recommended)

Display 1024 x 768 (minimum) 1280 x 1024 or higher (recommended)

Java Runtime Environment: Oracle's Java 7

PDF Reader to view User Guide Adobe Reader (recommended)

 2.2. Mac OS X

Operating System: Intel Mac OS X Snow Leopard 10.6.8 or above

Processor: 64 bit, Intel based

Free Disk Space: 5 - 50 MB

System Memory: 1 GB (mimimum)

Display 1024 x 768 (minimum), 1280 x 1024 or higher (recommended)

Java Runtime Environment: Apple's Java 6 (recommended) or Oracle's Java 7 (on Mac OS/X 10.7 and 
above)

PDF Reader to view User Guide Adobe Reader (recommended)
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 3. Installation

 3.1. Windows

Java Runtime Environment:

The most up to date Java Runtime Environment (JRE) for Windows, can be downloaded and installed from 
http://www.java.com.

Installation Instructions:

IMPORTANT: PWMinder must be installed by a user with Administrative privileges.

1. Download PWMinderSetup_3.0.x.x_noJRE.exe, (or PWMinderSetup_3.0.x.x_JRE.exe if you 
would like to include a bundled JRE).

2. Run the setup file (by double-clicking it).
3. Click Allow if prompted whether to allow the installer to run.
4. Follow the instructions in the installation wizard.

NOTE: PWMinder will be installed for all users.

 3.2. Mac OS X

Java Runtime Environment:

PWMinder requires Java SE 6 (recommended) or Java SE 7 on Mac OS X.

Mac OS X 10.6 (10.6.8) Snow Leopard
Apple Java 6: Can be downloaded from Apple: http://support.apple.com/kb/dl1573

Mac OS X 10.7 (10.7.3) Lion and  above
Apple Java 6: Can be downloaded from Apple: http://support.apple.com/kb/dl1572
Oracle Java 7: Can be downloaded from Oracle: http://www.java.com/en/download/manual.jsp

Installation Instructions:

1. Download PWMinder3.0.x.x_JRE6.dmg (or PWMinder3.0.x.x_JRE7.dmg)
2. Double-click the .dmg file.
3. Drag the PWMinder icon to the Application Icon

 3.3. Upgrading PWMinder Software

To upgrade from a previous version of PWMinder execute the following steps:

1. Uninstall the old version
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2. Install the new version of PWMinder (see above)

 3.4. Upgrading Repository Files

If you are upgrading from an earlier version of PWMinder (version 2.5 and earlier), your password Repository 
file(s) will need to be upgraded.

Important: For Mac Users, before upgrading, make the Repository file is not locked.  If it is locked, 
please unlock before upgrading it.  See Section 22.2 for more information on locked files.

To upgrade an old Repository, execute the following steps:

1. Open the old Repository file using PWMinder 3.0
2. The following message will be displayed:

3. Click OK.
4. After the Repository has been upgraded a confirmation message will be displayed.
5. Click OK.
6. The Repository will now be available for use in PWMinder 3.0

NOTE: The original Repository will have been backed and renamed, but is otherwise unchanged and is 
available if needed.  The original repository will have a name like: Repository_2.5.pwm.bak
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 4. Starting PWMinder

 4.1. On Windows

1. Go to Start menu.
2. Go to PWMinder Program Group.
3. Click on PWMinder icon.

 4.2. On Mac OS X

1. Go to Applications, in Finder
2. Double-Click on PWMinder.app

 4.3. On Mac OS X using Launchpad (OS X 10.7 and higher)

3. Open Launchpad
4. Double-Click on PWMinder Icon

 4.4. System Tray (Windows)

PWMinder has the option to be minimized to the System Tray (i.e. It will no longer appear in the Task bar, but a
small Icon will remain in the System Tray).   PWMinder can be restored by right-clicking on the System Tray 
icon and selecting Restore PWMinder.  Other options from the System Tray icon are Options and Exit 
PWMinder.  The minimizing to System Tray feature can be enabled or disabled in the Options window (see 
Section 1  6  .4  )

 4.5. Dock (Mac)

PWMinder can be added to the Dock, by dragging PWMinder.app from Finder to the Dock.  PWMinder can 
then be started by clicking on the icon in the Dock.

 4.6. Welcome Screen

Normally, when PWMinder starts, it will attempt to re-open the last used Repository file, and prompt for its 
password.  If it is the first time PWMinder has been run, or if it can't find the last used Repository file, PWMinder 
will display a Welcome screen, which provides several options, to get started:
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New Used to create a New Repository.  See Section 6.2 

Open Used to open a Local Repository.  See Section 6.3

Open Dropbox Used to open a Dropbox Repository.  See Section 6.4

Integrate Used to integrate PWMinder with a Dropbox account.  See Section 19.1

The Welcome Screen can also be displayed by clicking on the File->Welcome Screen menu item, when no 
Repository file is open.

 4.7. Shutting Down

It is important to shut down PWMinder before logging off your computer or before shutting your computer off.  If 
you fail to shut it down properly, the Repository file you were using, may remained locked.  To unlock the 
Repository file see Section 6.6
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 5. Uninstall PWMinder

NOTE: Uninstalling PWMinder will not remove any setting, Registration codes or Repository files.

 5.1. Windows XP, Vista, Windows 7

IMPORTANT: PWMinder must be uninstalled by a user with Administrative privileges.

1. Go to Start Menu
2. Go to PWMinder Program Group
3. Click on Uninstall.exe

 5.2. Windows 8, Windows 8.1

IMPORTANT: PWMinder must be uninstalled by a user with Administrative privileges.

1. Go to Control Panel
2. Select Programs
3. Select Uninstall a program
4. Find PWMinder
5. Click on Uninstall

 5.3. Mac OS X (PWMinder Versions 2.6 and older)

1. Go to Applications
2. Open PWMinder Folder
3. Open Uninstall Folder
4. Double-click on Uninstall.jar (or Right-Click and select Run With Java Jar Application)

 5.4. Mac OS X (PWMinder Version 3.0)

1. Go to Applications
2. Delete PWMinder.app
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 6. Repository Management

 6.1. General

In PWMinder, a Repository is the central storage place for all of your password records.  Each Repository has 
a name, description and password; and is saved as an encrypted file.  You can create as many Password 
Repositories as needed, e.g. one for home, one for work, or one for each members of the family, etc. 
Repository files can either be stored locally, or can be stored using Dropbox, allowing you access to you 
passwords on multiple computers and devices.

 6.2. Creating a Repository

To create a new Repository, execute the following steps:

1. Start PWMinder (or close any open Repository)
2. Select File->New (alternatively click on the Create New Repository icon on the Toolbar)
3. The following window is displayed:

4. Enter a name for the Repository (mandatory)
5. Enter a description for the Repository (optional)
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6. Enter a master password from the Repository.  Either enter your own password, or click on Generate... 
to have the Password Generator assist you, in creating a secure password (see Section 10 for more 
information about using the Password Generator)

7. Select whether the Repository File should be stored locally, or on Dropbox (Dropbox must have been 
integrated for this to work.  See Section 19 for instructions on integrating with Dropbox)

8. For Local files, use the default file name and location, or use the Browse... button, to browse to a 
location on the file system, where the Repository file should be saved.  Enter a name for the Repository 
file; the default name is the same a the name for the Repository (it is recommended to use this name).

9. Click OK, to create the Repository.

Important: The password you use for the Repository should be as secure as possible since it is the 
password that will be protecting all of your other passwords.  Please use the Password Strength Meter 
only as a guide to the quality of your password.

Warning: Make sure you remember this master password, since it will be the only way to access the 
Repository.  For security reasons, the password is not stored anywhere and so if it is forgotten, it 
cannot be recovered!

 6.3. Opening a Local Repository

Note:  When starting PWMinder, it will automatically attempt to open the last used Repository, by prompting for 
a password.

1. Start PWMinder application.
2. Make sure no other Repository is open.
3. Select File->Open Local Repository  (alternatively click on the Open Repository icon on the Toolbar).
4. Browse to the Repository file (it will have a .pwm extension).
5. Click Open.
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6. Enter the password for the Repository (Note: Passwords are case sensitive).
7. Click OK.

Note: If an incorrect password is entered (or a file, other than a Repository file was selected) the following 
message will be displayed:

 6.4. Opening a Dropbox Repository

Note:  Before you can open a Dropbox Repository, Dropbox must be integrated with PWMinder.  (See Section 
19 for instructions for integrating with Dropbox).

1. Start PWMinder application.
2. Make sure no other Repository is open.
3. Select File->Open Dropbox Repository  (alternatively click on the Open Dropbox Repository icon on the 

Toolbar).

4. Select the Repository file you wish to open
5. Click Open.
6. Enter the password for the Repository (Note: Passwords are case sensitive).
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7. Click OK.

 6.5. Modifying a Repository

To modify an existing Repository, execute the following steps:

1. Start PWMinder application.
2. Open the Repository to be modified.
3. Select File->Modify Repository...
4. Modify the name, description or password, and then click OK to modify the Repository.

 6.6. Repository Locking

You are allowed to open several instances the PWMinder on your computer so you can have multiple 
Repository files open at the same time.  Each Repository file, however, may only be open in one instance of 
PWMinder at a time.  If you try to open a Repository file, that is already open in another instance the following 
message will be displayed:

NOTE: If PWMinder does not get shut down properly (for example, the computer gets shut down, without 
having first, closed PWMinder), the Repository file may remained locked, and you will be unable to open it.  To 
unlock a file, Browse to where the file is saved (hint, you can use the Browse... button) and delete the 
associated lock file.  Example if file is Demo.pwm, the lock file will be Demo.pwm.lock~.  After deleting the 
lock file, you can open the Repository file normally again. 

 6.7. Saving a Repository

The Repository data is automatically saved to the Repository file, whenever a change is made.  The following 
actions trigger the Repository to be saved:

• Repository info is modified
• New Category is added
• Category is modified
• Category is deleted
• New Record is added
• Record is modified
• Record is deleted

NOTE: When a repository is saved, a backup of the original file is created with the extension .bak.  This can 
be useful, in case anything happens during the Save process or if you accidentally saved some incorrect data.  
To revert to the backup copy, either move or delete the original file, and then remove the .bak extension of the
backup file.  If you are using Dropbox, you can also use Dropbox's revert feature to revert to an older version of
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the file.

 6.8. Saving an existing Repository to a new File

To save a Repository to a new File, execute the following steps:

1. Open the Repository.
2. Select File->Save As... 
3. Browse to a Location on the file system, where the new Repository file should be saved.
4. Enter a new file name for the Repository file.
5. Click Save to save the Repository file.

 6.9. Closing a Repository

To close a Repository, select File->Close.  If any changes have been made to the Repository, a prompt will be 
given to save the Repository.  After a Repository has been closed, the Repository file is set to read-only (i.e. 
not writable), to guard against accidental modification or deletion outside of PWMinder.

 6.10.Repository Info

To display the Repository info, either Right-Click on the Repository, in the Repository Tree and select 
Repository Info, or select File->Repository Info.  The following information is displayed:

Name: The name of the Repository
Description: The description given to the Repository.
File: The file name of the Repository File.
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Location: The full path to the folder of a local Repository file, or the Dropbox path of the Repository file on 
Dropbox.
Size: The size of the Repository file.
Created On: The date the Repository was initially created.
Last Modified.  The date the Repository was last modified and saved.
Dropbox Rev: The Dropbox rev (only shown for Dropbox Repositories).
Version: The version of the Repository.  Note: This is the version of the Repository structure, not the data in it, 
nor the version of the PWMinder software application.
Read Only: Flag for whether the Repository file is Read Only or Writable.

 6.11. Re-naming a Repository file.

Since Repository files are just files on the file system, if the Repository file needs to be re-named, use the 
Operating System to rename it.  Alternatively, use Save As, to save it to a different file.  For a Dropbox file, use 
the Dropbox interface (e.g. Dropbox Web Interface) to rename the file.

 6.12.Deleting a Repository file.

Since Repositories are just files on the file system, if a Repository is no longer needed, it can simply be 
deleted.  For Dropbox files, use the Dropbox Interface to delete the file.

WARNING: Once a Repository file has been deleted from the file system, all stored passwords will be 
lost,  please be sure the data is no longer needed, or has been backed up, before deleting it.
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 7. Categories

 7.1. General

In PWMinder, Categories are used to categorize Records into logical groups.  Each Record belongs to one 
Category.  PWMinder contains the following standard Categories:

Record Type Usage

Alarm System Use this to store passwords and account information for alarm systems.

Bank Account Use this to store passwords and account information for bank accounts.

Cell Phone Cell Phone PINs

Computer Account Using this to store logins and passwords for computer accounts.

Credit Card Credit Card information.

Email Account Use this to store user names and passwords for email accounts.

Misc Use this to store any miscellaneous user names and password.

Software Account Use this to store user names, password, registration keys, etc. for software.

Web Site Use this to store logins and passwords for web sites.

 7.2. Custom Categories

In addition to the standard Categories listed above, Custom Categories can be created.  Please note: any 
custom categories created will only apply to the Repository to which they are added (i.e. each Repository can 
have its own custom Categories).  In the Repository Tree, Custom Categories will be displayed with blue 
folders to distinguish them from standard Categories.

 7.3. Manage Custom Categories

To manage Custom Categories, select Categories->Manage Categories (alternatively, click on the Manage 
Categories icon on the Toolbar) and select the Custom Categories tab.  The following window is displayed:
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This window lists all the Custom Categories, and allows new Categories to be added, or existing Categories to 
be modified or deleted.  See details below for each action.

 7.4. Add a new custom Category

To add a new custom Category execute the following steps:

1. From the Manage Custom Categories Window click Add  (alternatively, click on the Add Custom 
Categories icon on the Toolbar, or select Categories->Add Category from the menu bar).

2. The following Window is displayed:
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3. Enter a Name for the new Category (mandatory). NOTE: the name may not contain the double-quote (“) 
character, and must be unique.

4. Enter a Description for the new Category (optional).  The description will be displayed in the tool tip 
when the mouse is hovered over the Category in the Repository Tree.

5. Click OK.

 7.5. Modify a Custom Category

To modify an existing custom Category, click on the Category in the Manage Categories Window, and then 
click Modify (alternatively, select the Category in the Repository Tree and then right-click and select:  Modify 
Category: “XXX”.  Modify either the Name or Description and click OK.

 7.6. Delete a Custom Category

To delete an existing custom Category, click on the Category in the Manage Categories tab, and then click 
Delete (alternatively, select the Category in the Repository Tree and then right-click and select:  Delete 
Category: “XXX”.  Click Yes when prompted to confirm.  NOTE: You can only delete a Custom Category if it 
has no Records associated with it.

 7.7. Hide a Standard Category

There may be cases where one or more of the Standard Categories provided are not needed and just get in the 
way.  To help with this, Standard Categories can be hidden, so they don't show up in the Repository Tree.  To 
hide a Standard Category select Categories->Manage Categories and then select the Standard Categories tab:
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To hide a Standard Category, click on the Hidden check box, next to the Category.  NOTE: You can only hide a 
Standard Category, if it has no Records associated with it.

To make the Standard Category visible again, click on the Hidden check box again.

 7.8. Expanding/Contracting the Repository Tree

The entire Repository Tree can be expanded, by right-clicking on the Repository node and selecting Expand 
All.  To collapse the Repository Tree select Collapse All.

 7.9. Grouping Records by Category

By default, the Repository tree view groups Records by their Category.  This can to toggled on and off by 
clicking on the check-box called: Group Records by Category.
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 8. Records

 8.1. General

In PWMinder a Record stores an individual password and all its related information.  Records are grouped by 
Categories and stored in the Repository.

 8.2. Adding a new Record

To add a new Record, execute the following steps:

1. Make sure the desired Repository is open.
2. Select Record->Add from the menu (alternatively click on the Add Record icon on the Toolbar, or enter 

Alt+A)
3. The following window is displayed:
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4. Enter a Name for the record (mandatory).  NOTE: the name may not contain the double-quote (“) 
character, and must be unique.

5. Select a Category for the record.
6. Enter a description (optional).  The description is displayed in the tool tip when hovering the mouse over 
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a record in the Repository tree.
7. Enter a Login (e.g. Username) for the record (optional).  Previously used Logins can be accessed by 

either clicking on the down arrow button with the mouse, or by use the down arrow on the keyboard.  It is
recommended not to use quotations marks “, in logins, since they can lead to unexpected results, when 
searching.

8. Enter the password for the record. If you already have a password, enter it here; if you want to generate 
a new secure password click Generate. (see Section 10 for more information about using the Password 
Generator).

9. Enter an Account Number (optional)
10. Enter a URL (e.g. URL for web sites, or URL of ISP, Software Company, etc.)   (optional).  NOTE: there 

is no need to enter the http:// part, this will be added automatically.
11. Enter an email address associated with the record (optional)
12. Enter a security question (optional)
13. Enter the security question answer (mandatory if security question is entered)
14. If you want PWMinder to remind you to change your password, select an Expiry date, by un-checking 

the Expiry box and then clicking on the calendar button, to select a date.
15. Click OK, to add the new Record.

 8.3. Modifying an existing Record

To modify an existing Record, select the Record in the Repository tree, and then select Record->Modify, or 
select the Modify Record icon from the Toolbar, or right-click and select:  Modify Record: “XXX”, or double-click 
the Record.
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Any field can then be edited including the Category.

 8.4. Moving a Record to another Category

If a record needs to be changed, to belong to a different Category, the Record can be dragged from one 
Category to another within the Repository Tree.

 8.5. Deleting a Record

To delete a Record select the Record in the Repository tree, and then select Record->Delete, or select the 
Delete Record icon from the Toolbar, or right-click and select:  Delete Record: ”XXX”

WARNING: the Repository file will be saved, right after a Record is deleted and the Record cannot be 
recovered so be careful when deleting a Record.
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 8.6. Viewing a Record's Details

To view the contents of a Record, find it in the Repository tree, and click it, or select Open Record Details, from
the Record's right-click menu.  The Record's information is displayed on the right panel.  For security reasons, 
the password is displayed as: **********.  To view the password in plain text, click the Display button.  The 
following window is displayed:

Click on the Copy button, to copy the password to the clipboard, allowing for pasting on to website login form, 
or other software.

NOTE: If a URL or eMail has been entered, clicking on the field will open up the default browser or email client,
respectively.

 8.7. Quick Copy of Login and Password

Clicking on the Copy button, next to either the Login or Password fields, will copy the value to the clipboard, so 
it can easily be pasted on to a website Login form, or other application.  Alternatively, right-clicking on a 
Record, in the Repository Tree, and selecting Copy Login or Copy Password, will copy the Login or Password 
respectively.

 8.8. Password Expiry

If a Record has an expiry date set for it, and the expiry date has passed, the Password Expiry Date is 
displayed in Red, as a warning.

The actual password, that this Record is for, should be changed, and then the Record should be modified, to 
make it consistent with the change.  The Expiry Date should also be reset to a future date, to set up another 
reminder.  If you no longer want want a reminder that the password has expired, the Expiry Date can be 
removed, by checking the No Expiry check box.

 8.9. Recent Records

You can access your most recently used Records by selecting Record->Recent Records.  This will display a list
of the most recently used Records, for easy access.  To clear this list, select Records->Recent Records->Clear
Records.
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 8.10.Record Tabs

Multiple Records can be opened at one time, with each Record being displayed in a separate Tab.  This make 
it easy to access your most often used Records.  To close a Tab, hover over the top right corner of the tab, and 
click on the X.

 8.11. Record Toolbar

On the Record Details panel, there is a toolbar which allows you to manage the Record:

Modify Allows you to modify the Record details

Delete Deletes the Record

Info Provides some more details about the Record

Favourites Adds/Removes the Record from Favourites

 8.12.Sorting Records

The Records in the Repository tree can either be sorted by Name or by Login.  To change the sort, click on the 
Sort button, below the Repository tree.  The following window is displayed:

The Records can be sorted either by Name or Login and either Ascending or Descending.  Note: If the Records
are grouped (See Record Type), then they will be sorted within the Record Type category.

 8.13.  Favourites

Record that are used often, can be marked as a Favourite.  Records that are marked as a Favourite are 
displayed in Favourites Node, at the bottom of the Repository Tree, for easy access.  Favourite Records are 
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also shown in Green, in the Repository Tree.  To mark a Record as a Favourite, right-click the Record in the 
Repository tree and select Add to Favourites.  To remove a Record from Favourites, select Remove from 
Favourites.

 8.14.Searching for a Record

To search for a Record, execute the following steps:

1. Click on the Search button under the Repository Tree, or the Search button in the Toolbar (alternatively, 
right-click on the Repository node in the Repository Tree and click Search).

2. The following Window is displayed:

3. Enter the parameters to search by.
4. Click Search button
5. The Repository Tree is displayed with any Records that match the Search.  Note: The Repository Icon is 

changed to a search icon, to indicate that only Records matching the search are displayed.
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6. To cancel the search (and display all Records), click on the Cancel button under the Repository Tree or 
the Cancel Search button in Toolbar (alternatively, right click on the Repository node in the Repository 
Tree, and click Cancel Search).

 8.15.Search Rules

1. When searching for Records, a Record is considered a match if the search parameter is contained 
anywhere in the actual value.

Example: Searching for one of Win, Window or Windows in the name field will match a name field of 
Windows

2. Leaving a field blank will match all value

Leaving the Name field blank will match Records with any Name value.

3. Searches are not case sensitive.

Example: Both WIN and win will match Windows

4. Search parameter have an AND relationship

Example:  Search for Name=Windows, Category=Computer Account, Login=Joe will only match 
Records that have a Name matching Windows AND are in category of Computer Account AND have a 
Login matching Joe

5. Quotation marks (“) are ignored when used in search parameters.

Example: Search for a Login of “test” will match records with logins like “test”, “test and test.  A known 
issue with this, however, if a login has a “ inside it, it won't be found in a search, e.g. login of te”st won't 
be found when searching for te”st since the “ is ignored.

 8.16.  Quick Search in Repository Tree

Records and Categories can also be searched for, directly from the Repository Tree, by using Quick Search. To 
use Quick Search, execute the following actions:

1. Select the Repository Tree
2. Begin Typing
3. The Quick Search field is displayed showing what you have typed.  Any Record or Category that 

matches what you have typed is automatically selected in the Repository Tree.
4. Use the up and down arrow keys to go back and forth between matches.
5. To cancel Quick Search, click ESC button.

Quick Search Example:
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Note: Quick Search only matches the beginnings of words and is case-insensitive.
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 9. Auto Login

 9.1. General

For web site based records, PWMinder supports Auto Login, where PWMinder can be used to open the web 
site in a browser, and then automatically type in the login and password.

 9.2. Configuration

To set up Auto Login, execute the following steps:

1. Modify a Record.
2. On the Modify Record Window, click on the Configure Auto Login button.  NOTE: this button will only be 

enabled if the Login, Password, AND Website (URL) fields have values set for them.
3. The following Window is displayed:

4. Modify the URL if necessary (this has been pre-populated with the value already entered on the Modify 
Window).

5. Enter a delay value (in seconds).  This is delay time, between when the browser is opened and when the
Login Sequence is initiated.  The value to put in here will depend on connection speed, browser speed 
and how long it takes the web page to load.  Valid values are from 1 to 99.

6. Enter the Login Sequence, but using the four buttons below.  The Login Sequence can consist of the 
login value for the record (${login}), tab key(${tab}), the password for the record(${password}), and the 
enter key (${enter}).  A typical login sequence would be login -> tab -> password -> enter (i.e. ${login} $
{tab} ${password} ${enter}).  In some cases a tab may need to be used before the login, or possibly two 
tabs before the password.

7. Click on the Test button to test the auto login.
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8. Click OK when done.

 9.3. Execution

To use the Auto Login feature, on the Record Details screen, click on the Auto Login button.  NOTE: this button
will only be enabled, if Auto Login has been configured for the record.

Limitations

1. Auto Login only works with US Layout keyboards (international keyboard not yet supported)
2. Auto Login only supports logins and passwords that contain the following characters:

• Letters A-Z and a-z (international characters not yet supported)
• Digits 0 to 9
• The following special characters: !@#$%^&*()_+-={}|[]\:”;'<>?,./

3. Auto Login will only work for Web Pages where the login can be accomplished using keyboard only, 
using tabs and enter.  If the web page only allows access to the login fields using mouse clicks then Auto
Login will not work.

HINT: some web site require you to click on a “Log On”, button, which takes you to a second web page that 
allows you type your login and password.  In these cases, the second page's URL should be the one used in 
PWMinder.

 9.4. Examples

Gmail

In the Record Details screen set you gmail username and password.
In the Auto Login Designer set up the following:

URL: http://mail.google.com
Delay: 10s (will depend on Computer and Connection speeds)
Login Sequence: ${login} ${tab} ${password} ${enter}

Facebook

In the Record Details screen set the login to your facebook email address, the password to your facebook 
password and the URL to http://www.facebook.com/login.php

Depending you which browser you use, and how your cookies are set up, and whether you have logged in 
before, the facebook login site may or may not already pre-populate the Email: field.

If, in your browser, the Email field is already filled in when going to the login site, use the following in the Auto 
Login Designer Login Sequence:

${password} ${enter}

If, in your browser, the Email field is not already filled in when going to the login site, use the following in the 
Auto Login Designer Login Sequence:
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${login} ${tab} ${password} ${enter}
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 10.Password Generator

PWMinder includes a Password Generator which can help to generate more secure passwords.  It can be 
accessed by clicking on the Generate... button while creating or modifying a Repository, or when adding or 
modifying a Record.  It can also be accessed using the Tools->Password Generator... menu.

 10.1.Usage

1. Select the number of characters that the password should be (minimum of 10 is recommended)
2. Select whether the password should contain Alpha only characters, Numeric only characters or Alpha 

Numeric characters (Alpha Numeric is recommended)
3. If Alpha or Alpha Numeric was selected, select whether the password should be Upper Case only, Lower

Case only or Mixed Case (Mixed Case is recommended)
4. Enter a Special Character that should be included in the password.  Make sure the system that this 

password is being created for, accepts the Special Character chosen.  If no special character is to be 
included, remove any character from the Special Character field.

5. Click Generate button
6. Click Copy to copy the password to the clipboard so it can either be pasted into PWMinder or into any 

other application.

NOTE:  The Password Strength meter is meant to giving a general idea of how Weak or Strong the 
password is.  A password with a 'Very Strong' rating does not guarantee that the password can't be hacked.
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 11. Message Digest Calculator

 11.1. General

PWMinder contains a tool to use to calculate the Message Digest (Hash) of a Text String or File, using one of 
several hashing algorithms.  A Message Digest is a way of representing a piece of Text, or a File as a string of 
digits.  Ideally every different piece of text or file produces a different Message Digest, but the same pieces of 
text or same files should produce the same Message Digest.  PWMinder supports MD5, SHA-1, SHA-256 and 
SHA512 hash algorithms.

 11.2. Usage

To use the Message Digest Tool execute the following steps:

1. Select Tools->Message Digest from the menu
2. The following window is displayed:
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3. Select the Message Digest hash algorithm you would like to use.
4. To calculate the Message Digest for a text String, type or paste the String into the text area.  To 

calculate the Message Digest for a file, select the file using the Browse... button.
5. Configure how you would like the Message Digest to be displayed (for example with all capital letters, 

or with each Hex Characters separated by a colon.
6. Click on Calculate.
7. To compare this calculated value with a reference value, copy the reference value into the Compare 

To: field and click Compare.  NOTE: The calculated value and the reference value must be displayed 
in the same format.
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 12.Encryption

 12.1.General

PWMinder includes a tool that allows you to encrypt files on your computer to help protect their contents.  The 
files can then later be decrypted to view their contents.

 12.2.Encryption Usage

To encrypt a file execute the following steps:

1. Select Tools->Encryption from the menu
2. The following window is displayed:

3. Select the Encrypt tab
4. Use the Browse... button to select the file you would like to encrypt
5. Use the Browse... button to select where you would like to save the encrypted file to.  By default the 

name of the encrypted file will be the same as the original file, with a .pwmcrypt extension.
6. Select the Encryption algorithm you would like to use, it is recommended to used the default of AES 

(128) with CBC. (WARNING: Make sure you remember which encryption algorithm you used, as 
this will be needed for decryption).

7. Click on the Encrypt button.
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8. Enter the password you would like to use (WARNING: Make sure you remember this password, as 
it will be required to decrypt the file.)

9. Click OK, to begin the encryption.

NOTE: It is a good idea to test that the decryption works before deleting the original file.

 12.3.Decryption Usage

To decrypt a file execute the following steps:

1. Select Tools->Encryption from the menu
2. The following windows is displayed
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3. Select the Decrypt tab
4. Use the Browse... button to select the file to decrypt (this file should have a .pwmcrypt extension).
5. Use the Browse... button to select where to decrypt the file to.  By default the file will have the same 

name as the encrypted file, but with the .pwmcrypt extension removed.
6. Select the algorithm to use, to decrypt the file (Make sure you use the same algorithm that was used 

to encrypt the file.)
7. Click on the Decrypt button.
8. Enter the password (Make sure you use the same password that was used to encrypt the file).
9. Click OK, to begin the decryption.
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 13.File Shredder

 13.1.General

PWMinder includes a tools that shreds files on your computers.  When normally deleting a file, it goes into the 
Recycle Bin, or Trash so it can be easily recovered.  Even when files are permanently deleted from the Recycle 
Bin, remnants of the file can still remain on the hard drive and can sometimes be recovered.  In some cases this 
is good (if you accidentally delete a file), but in other cases you may have sensitive data that you would like to 
completely remove.  PWMinder can permanently delete a file by over-writing the data with random bits of data, 
making it much more difficult to recover the data.

 13.2.Usage

1. Select Tools->File Shredder... from the menu
2. The following window is displayed:

3. Use the Browse... button to select the file you would like to shred.
4. Select the Number of Passes.  This is the number of times the data will be over-written.  The more times 

the data is over-written, the greater the security, but the longer it will take.
5. Select whether to over-write the data zeros on the final pass.
6. Click on the Shred button
7. Confirm that you want to permanently delete the file.

WARNING: After a file has been shredded it may be impossible to re-cover.  Please make sure you want 
to permanently delete the file.
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 14.Export

 14.1.General

PWMinder allows for the data in a Repository to be exported into various formats.  NOTE: the expiry date in the
export, will be formatted in the same way as it is displayed (as specified in Options).

 14.2.Procedure

To export data, execute the following steps:

1. Select Tools->Export from the menu (alternatively, click on Export in the Toolbar).
2. The following window is displayed:

3. Select whether or not the passwords should be exported in Plain Text or be masked as ******* 
(WARNING: it may be insecure to have the passwords exposed as plain text.)

4. Select whether the Records should be grouped by their Categories or not.
5. For HTML export, select whether the Records should be displayed in a simple table or into an expanded 

format, that displays each Record's data is its own table of name/value pairs (see Appendix for 
examples).

6. Select an export format (HTML, XML, or CSV)
7. For CSV, select the character encoding to use (UTF-8 is recommended).
8. Select a file to export to.
9. Click on Export.
10. When the export is complete, a confirmation message is displayed.
11. If you would like to open the export file, using the system default application,  click Yes.

Important: Be careful when manually editing the export file name, to use the correct extension, 
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otherwise the file could be exported with an incorrect extension, e.g. HTML file gets exported with a 
.csv extension.   To fix this, if it happens, simply use the file system to rename the file extension.

 14.3.Export formats

HTML

Repositories can be exported to an HTML format, suitable for viewing and printing.  HTML exports have two 
options, compact and expanded.  In compact, records are displayed in a tabular format, one record per row.  In 
expanded format, each record is listed separately in a set of name value pairs.

Examples:

Compact

Records:

Name Description Login Password 
Account
Number 

URL Email Notes 
Security

Question 

Security
Question
Answer 

Expire
Date 

Savings
Savings 
Account

abc ********** 987
http://www.ba
nk.com 

my@do
main.co
m 

What is your 
favourite 
colour?

Black 2010-03-26

Expanded

Savings 
Description: Savings Account.

Login: abc

Password: ********

Account Number: 987

URL: http://www.bank.com 

Email: my@domain.com 

Notes:

Security Question: What is your favourite colour?

Security Question Answer: Black

Expiry Date: 2010-03-26

XML

Repositories can be exported to XML format.  The XML format can be used to programmatically exchange data
with other systems, or can be used with css style sheets to create custom HTML displays.  A full example of the
XML export can be found in Appendix 2 – Export

CSV

Repositories can be exported to CSV suitable for opening in a spreadsheet.  The data fields, in the export file 
are separated by tabs, and records are separated by line feeds.
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 15.  Import

 15.1.  General

PWMinder allows for the import of data into a Repository.  The data must be in the format of a tab-delimited file.

 15.2.  Procedure

1. Select Tools->Import from the Menu.
2. The following Window is displayed.

3. Select a file to import (must have .csv or .txt extension).
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4. Select the encoding that the file was created in (see Section 15.5 for more information)
5. Click on the Import button
6. After the import has completed, results will be show in the Import Results.  Review these results to see 

if there were any Errors or Warnings.  NOTE: The Console results can be copied to the Clipboard and 
pasted into a Text Editor, for future reference.

Results Summary

At the end of the Results the following summary is given:

Import File: The file that was imported
Encoding used during import: The encoding used, e.g. UTF-8
Number of Lines:  The number of lines in the import file
Number of Lines ignored: The number of lines that did not appear to have any relevant data
Records attempted: The number of lines that appear to have record data
Records imported: The number of records that were successfully imported
Records with warning: The number of records that were imported, but had warnings, such as fields 

that were too long
Records failed: The number of records that were attempted but failed, e.g. because name was 

missing, etc.

 15.3.File Format

The import file must be a simple tab delimited text file (i.e. each field is separated by a tab character).  Each 
line in the text file will contain the data for one Record that is to be imported.  The import file should not contain 
any other lines of data, other that the data to be imported.  The following table lists the fields, their format, 
whether or not they are required, and the maximum length. (NOTE: Empty fields must also be separated by 
tabs).

Field No. Field Comments Max Length

0 Name Required; may not contain “ character, and may
not be already used.

50

1 Category Name Not required; if not specified, the record will be 
assigned to the Misc Category; if not found s 
new a Category with this name is created.  May
not contain “ character

50

2 Category Description Not required, only used if new Category is 
added

100

3 Description Not required 150

4 Login Not required 50

5 Password Required 50

6 Account Number Not required 30

7 URL Not required; if specified it must be valid URL 320

8 Email Not required; if specified it must be valid Email 320
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9 Notes Not required 250

10 Security Question Not required 150

11 Security Question Answer Not required unless security question is given 50

12 Expiry Date Not required but if specified must be in format: 
yyyy-MM-dd

10

Validation

A record will fail to be imported if the name or password are missing, or the name already exists.

If data in a field is too long, the data will be truncated.  A warning will be given but the record will still be 
imported.

If the email or URL fields are invalid, or too long then they will be ignored (not included).  A warning will be 
given, but the record will still be imported.

If a Security Question is supplied, but no Answer is supplied, the Security Question field will be ignored (not 
included).  A warning will be given, but the record will still be imported.

If the Expiry date field has invalid format, it will be ignored (not included).  A warning will be given, but the 
record will still be imported.

 15.4.  Tips for Creating import files

The easiest way to create a tab delimited file is to use a spreadsheet program like LibreOffice Calc.  You can 
enter your data into the spreadsheet, and then save it as Text CSV, making sure you set the field delimiter to 
TAB, and the Text delimiter to none.  Also make note of the Characters Set, as you will need to match this, 
when importing.  It is recommended to use UTF-8.
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 15.5.  Encoding

The import function supports the following file encodings (Characters Sets):

Encoding (Character Set) Comments

UTF-8 Default and recommended encoding

ISO-8859-1 Available on all Operating Systems

US-ASCII Available on all Operating Systems

windows-1252 Available only on Windows

MacRoman Available only on Mac OS/X

NOTE: When creating your import file, it is recommended, to use UTF-8 as it is universally accepted across all 
languages and Operating Systems.

When importing, make sure you select the encoding, that matches the encoding that was used when creating 
the import file.
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 16.Options/Preferences

 16.1.General

PWMinder has several user options/preferences.  To open the options window click on Tools->Options... 
(alternatively click on the Options icon on the Toolbar).  On Mac, select Preferences... from the Application 
Menu. The following window is displayed:
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 16.2.Look and Feel

PWMinder currently supports the following Look and Feels:

Look and Feel Description

System This Look and Feel attempts to match, as closely as possible, the Look and Feel of the 
current Operating System.  This is the default Look and Feel, when installing PWMinder.

Nimbus A new cross-platform Look and Feel, developed by Sun.  This Look and Feel requires 
Java 6 update 10, or higher.

JGoodies Windows A Standard Windows-Like Lood and Feel from jgoodies.

JGoodies Plastic 3D An elegant multi-platform Look and Feel from jgoodies.

EaSynth Default Look and Feel for EaSynth Look and Feel Designer.

Quaqua An enhanced Mac OS X Look and Feel (for Mac OS X only)

 16.3.Date Format

This options allows for the setting of the date format for the Record expiry date.  The following date formats are
supported.

Format Description

Default Long The default long date format set up on the users computer (based on locale of the O/S)

Default Short The default short date format set up on the users computer (based on locale of the O/S)

yyyy-MM-dd (ISO) The ISO standard date format (Recommend)

dd/MM/yyyy Common date format.

dd.MM.yyyy Common date format.

mm/dd/yyyy Common date format.

When selecting different date formats, an example of how it will be displayed, is shown below it.

 16.4.Misc Options

A set of miscellaneous options.

1. Max Password Attempts.  The maximum number of time you can try to enter the password for the 
Repository, before PWMinder is exited.

2. Dropbox Poll Interval.  How often PWMinder should check for updates to the Repository File on 
Dropbox.

3. Re-Open last Repository used.  When checked, when PWMinder is started, it will prompt for the 
Password of the last Repository that was used.  Otherwise you need to browse for the Repository you 
want to open.

4. Minimize to Tray.  When checked when PWMinder is minimized, it will disappear into the System Tray.  
To Restore from the System Tray, either double click the System Tray icon, or right-click on the System 
Tray icon and click on Restore PWMinder.  Note: This will be disabled on Mac, since it doesn't use the 
System Tray feature.
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5. Check for Updates at Startup.  When checked (off by default), PWMinder will automatically check for 
Updates each time it starts.

6. Re-Open Record tabs.  If checked, all of the Record Tabs that were previously opened will be restored at
start-up.

 16.5.Log Level

This sets the logging level for the log file. By default, this is set to ERROR, so only ERROR level message are 
written to the logs.
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 17.Software Activation

In order to keep using PWMinder after the 30 day trial period, an Activation Code must be purchased and used 
to activate the Software.  Ewert Technologies uses FastSpring (https://www.fastspring.com) as its third party 
transaction processing agent.  Purchasing an Activation Code can be made through FastSpring by going to the 
Ewert Technologies store hosted by FastSpring (http://sites.fastspring.com/ewerttechnologies/product/pwminder-
desktop).

 17.1.Purchase Activation Code Online

To purchase online go to PWMinder home page, http://www.ewert-technologies.ca/products/pwminder, click on
the Purchase link and then click on the Buy Now button.  This will take you to the Ewert Technologies store on 
FastSpring.

1. Click on Order Now
2. Enter Order Details
3. Select Payment Method
4. Enter Coupon code (if any)
5. Enter Your Payment details
6. Complete the Order

 17.2.Activate the Software

In order to Activate PWMinder, you need to have purchased an Activation Code.  You can purchase an 
Activation Code from the Ewert Technologies Store website.  Once you have an Activation Code, execute the 
following steps:

1. Click on Tools->Activate Software (This step can be omitted if you purchased directly from within 
PWMinder, using the Kagi Sales Assistant)

2. Copy the Activation Code into the Activation Code field.
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3. Click Continue

4. Enter your Name, a Password and an eMail address.  The password you choose will be required if you 
ever need to Re-Activate the software.  The eMail address is used to retrieve your password, in case 
you forget it.

5. Click on Activate
6. A message will be displayed that the Software has been Activated.

 17.3.  Re-Activate the Software

To Re-Activate the software, using a previously used Activation Code (e.g. if you need to re-install PWMinder on 
a new Computer), execute the following steps:
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1. Click on Tools->Activate Software

2. Copy the Activation Code into the Activation Code field.
3. Click on Continue
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4. Edit your Name if desired.
5. Enter your Current Password and a new Password.  The Current Password is the password you used 

when you initially activated PWMinder.  If you have forgotten this password, use the Send Password 
button, and the password will be emailed to the email address you used when you initially activated 
PWMinder.  The new Password will be needed if you ever need to Re-Activate the password again.

6. Click on Re-Activate
7. A message will be displayed that the Software has been Activated.
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 17.4.View Activation Information

Once PWMinder has been registered, the Registration Information can be viewed by executing the following 
steps:

1. Click on Help->About
2. Click on the Activation Information tab
3. The following is displayed:

To copy the information to the clipboard, click on the Copy button.
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 18.  Help Menu

The following describes the functions available under the Help menu.

 18.1.  User Guide

To Open a copy of this User Guide from within PWMinder, click on Help->User Guide.

IMPORTANT: You need to have Adobe Reader (or other PDF reader) installed for this to work.

 18.2.  Check for Updates

To check if there is a new version of PWMinder available, click on Help->Check for Updates.. If a newer version
of PWMinder is available, a message box will be displayed.  Clicking Yes on the message box will open your 
browser to the PWMinder download website.

 18.3.View Log

To view the Application logs, click on Help->View Log.
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This information can be useful, when trying to diagnose any problems.  The Information can be copied to the 
clipboard, using the Copy button.

 18.4.  About

To view Information about PWMinder, and your System Configuration, click on Help->About.  (On Mac click on 
About in the Application menu). The About window contains three tabs (About, Activation Information and 
Dropbox Information):
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This information can be copied to the Clipboard and should be included with any support issues.
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 19.  Dropbox

PWMinder can be integrated with Dropbox, allowing you to store and access your Repository files within 
Dropbox.  This allows you to access you password Repository file from different computers and devices, and 
also provides a back-up of your Repository file(s).  NOTE: in order to integrate PWMinder with Dropbox, you 
need to have a Dropbox account.

PWMinder Repository files are stored in the following folder in Dropbox:

/Apps/pwMinder

 19.1. Integration

Before you can begin using Dropbox with PWMinder, PWMinder needs to be integrated with your Dropbox 
account.  NOTE: PWMinder will only be able to access files in its own pwMinder folder within Dropbox and can 
not access any other files in your Dropbox account.  To integrate PWMinder with Dropbox execute the following
steps:

1. Click on Tools->Dropbox Integration...
2. The following window is displayed:

3. Click on the Get Code button, which opens the Dropbox Authorization Page:

PWMinder User Guide 60 of 83



4. If prompted, enter your Dropbox Login and Password and click Sign In.
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5. Click on the Allow button on the Web Page (which allows PWMinder to access your Dropbox account)

6. Copy the Authorization Code given, to the text field in the Dropbox Integration window
7. Click OK.

 19.2.Creating a Repository in Dropbox

To create a New Repository, that is saved to Dropbox, select the Dropbox option in the Create New Repository 
window.  The file will automatically be uploaded to the Apps/pwMinder folder in Dropbox.

NOTE: If the Dropbox option is not available in the Create New Repository window, that means that PWMinder 
hasn't been integrated with Dropbox.

 19.3.Opening a Repository in Dropbox

To open a Repository file stored in Dropbox, execute the following steps:

1. Select File->Open Dropbox Files... or click on the Open Dropbox File button on the toolbar.
2. Select the Repository file you would like to open.
3. Enter the password for the file.

 19.4.Refreshing Data from Dropbox

If you are accessing and modifying your Repository data from several devices or computers, you may want to 
refresh your data locally to make sure it is up to date.  To refresh your data click on File->Refresh menu item, 
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or click on the Refresh button on the toolbar.  If the data on Dropbox has changed you will be notified and 
asked to confirm, to Re-Load the data.  After Re-Loading the data, the Repository file will be closed and re-
opened and you will be prompted to re-enter your password.

 19.5.Automatically Check for Updates

PWMinder will also periodically check for any updates to the data in Dropbox.  By default it will check every 5 
minutes, but this can be configured in the Options.

 19.6.Move an existing Repository file to Dropbox.

If you have an existing Repository file, that you would like to start using with Dropbox, simply upload the file to 
the  /Apps/pwMinder folder in your Dropbox account (e.g. using the Dropbox Web Interface).  Then, the next
time you try to Open a Dropbox file, the file should be available.

 19.7.View Dropbox Information

To view your Dropbox Information execute the following steps

1. Click on Help->About
2. Open the Dropbox Information tab:
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 19.8.Clearing Dropbox Cache

When a Dropbox Repository file is opened in PWMinder, the file and associated information is stored locally.  
The cache folder is located at: <user>/.pwminder/DropboxCache (this location may be hidden on some 
systems).  If you would like to clear the contents of this cache folder, use Tools->Clear Dropbox Cache.

NOTE: To be able to clear the files, all Dropbox Repository files must be closed.  Please make sure you close 
all Dropbox Repositories in all instances of PWMinder before attempting to clear the cache.
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 20.  Administration

 20.1.Backing up Repositories

Because Repositories are stored as files on the computer file system, they can be backed up just like any file, 
by making a copy of it to another location.  It is recommended to periodically make a back-up a copy of your 
Repository files to a CD or other external storage, in case something happens to the original.

If you are using Dropbox for your Repositories, Dropbox automatically keeps the past several version of the 
file, which can serve as a Backup.

 20.2.Moving Repositories

Because Repositories are stored as files on your computer, they can easily be moved from one location to 
another, to a thumb drive, or even to another computer, by simply moving the Repository file.  Since PWMinder
runs on various Operating Systems, the file can even be moved to and used on a Computer using a different 
Operating System, than from what it was created on.  For example, a Repository can be created on a Windows
computer, and then copied and used on a Mac Computer.

Important: When a Read-Only file is copied from a Windows computer to a Mac computer, it may 
become locked.  The file must be unlocked before it can be modified and saved in PWMinder.
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 21.  References

 21.1.Repository Tree

Icon Description

Repository Node

Closed Category Node

Open Category Node

Closed Custom Category Node

Open Custom Category Node

Favourites

Record

 21.2.Menu Bar

Mac Application Menu

Menu Item Description Mac OS X Shot Cut 
Key

About PWMinder Display About Information

Preferences... Open the Preferences screen ,

Quit PWMinder Exit the Application Q

File

Menu Item Description Windows/Linux
Short Cut Key

Mac OS X 
Shot Cut Key

 Welcome Screen... Dispaly the Welcome Screen

 New... Create a new Repository Ctrl+N N

 Open Local Repository... Open a Repository from a Repository file Ctrl+O O

Open Dropbox File... Open a Repository file stored on Dropbox

     Recent Repositories Displays a list of recently opened Repositories

Refresh Refresh data from Dropbox

Repository Info Display information about the Repository

Modify Repository... Modify a Repository's information

 Save As... Save the current Repository to another file. Ctrl+Shift+S ⇧  S

 Close Close the Repository Ctrl+W W

 Exit* Exit the Application Alt+X
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Record

Menu Item Description Windows/Linux 
Short Cut Key

Mac OS X 
Short Cut 
Key

Recent Records Display a list of recently opened Records

 Add... Add a new Record to the Repository Alt+A A

 Modify... Modify the currently selected Record Alt+M M

 Delete Delete the currently selected Record DELETE DEL

 Add to Favorites Add the Record to the list of Favorites

 Remove from 
Favorites

Remove the Record from the list of Favorites

 Search... Search for a Record Ctrl+F F

Categories

Menu Item Description Short Cut Key

 Add Category... Add a new Custom Category to the Repository

 Manage Categories... Manage all Custom Categories

Tools

Menu Item Description

 Options...* Open the Options screen

 Password Generator... Open the Password Generator tool

 Message Digest Calculator... Open the Message Digest Calculator tool

 Encryption... Open the Encryption tool

 File Shredder Open the File Shredder tool

 Import... Import data into PWMinder

 Export... Export the Repository to various formats.

 Dropbox Integration Set up integration with Dropbox

 Clear Dropbox Cache Delete all of the locally cached Dropbox Repository files

 Purchase Registration Code... Purchase Registration Code using Internal Registration module

 Activate Software... Manually enter Activation Code

Help

Menu Item Description Short Cut Key

 User Guide Display the User Guide F1

 Check for Updates... Check for an updated version of PWMinder

View Log View the Applications Logs

  About* Display About Information
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* For Mac OS X, these items are in the Application Menu (see above).

 21.3.Tool Bar

Icon Description

Create a new Repository

Open a Repository from a Repository file

Open a Repository file stored on Dropbox

Refresh data from Dropbox

Cancel Search (only displayed when in Search mode)

Add a new Record to the Repository

Modify the currently selected Record

Delete the currently selected Record

Search for a Record

Manage custom Categories

Add a new custom Category

Open the Options screen

Import Data into the Repository
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Export the Repository

Display the About information, i.e. Information about the application

Exit the application
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 22.Trouble Shooting

 22.1.Support

If any problems occur while running PWMinder, please go to http://www.ewert-
technologies.ca/  home/  support.html  .   When submitting a support request, please include the PWMinder About 
information (see Section 18.4)

 22.2.File Locking on Mac

In addition to file permissions, on Mac computers, files can be set to Locked.  It also seems like when a Read-
Only file is copied from Windows to Mac, it becomes locked.  Locked Repository files cannot be saved in 
PWMinder so all Repository files should be unlocked prior to using them (e.g. after copying from a Windows 
computer).

To unlock a file, select the file in Finder, Right-Click and select Info.  In the 'General' pane, un-check the 
checkbox to unlock the file.

If a Repository is opened, and its file is locked, a warning will be displayed.

 22.3.Log File

PWMinder writes all error and other message to a log file.  This information can be useful when troubleshooting
problems.  The log file can be viewed by clicking on Help->View Log. 

The log file is written to the following location:
<user home>/.pwminder/log/PWMinder.log

On Windows XP this would be:
 C:\Documents and Settings\<user>\.pwminder\log\PWMinder.log

On Windows Vista this would be:
 C:\Users\<user>\.pwminder\log\PWMinder.log

On Mac OS X this would be:
 /Users/<user>/.pwminder/log/PWMinder.log

NOTE: the .pwminder folder may be hidden on some systems, to view hidden files/folder perform the 
following:

Windows:

In Windows Explorer got to Tools->Folder Options->View and then select Show hidden files and folders

Mac OS X:

At the command prompt enter:
defaults write com.apple.Finder AppleShowAllFiles TRUE (This changes Finder)
killall Finder (restarts Finder)
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Alternatively, use an application like Houdini or InVisible to display hidden folders.

Log Levels

By default, only ERROR level log messages are written to the log file.  The logging level can be changed on 
the Options screen (see Section 11.5).  The following log levels can be set:

Level Description

INFO The INFO level designates informational messages that highlight the progress of the 
application at coarse-grained level.  

WARN The WARN level designates potentially harmful situations.  

ERROR The ERROR level designates error events that might still allow the application to continue 
running 

FATAL The FATAL level designates very severe error events that will presumably lead the 
application to abort. 

 22.4.Known Issues

For any current Know Issues, and their work-arounds, please refer to the Release Notes available on the 
PWMinder Home Page: http://www.ewert-technologies.ca/home/products/pwminder-home.html.
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 23.  Appendix 1 - Password Creation Tips

When creating passwords for website, bank sites, etc, try to make the password as secure as possible.  Keep 
the following tips in mind to make it more difficult for your passwords to be cracked or guessed.

Do's

1. Use a password with at least 8 to 10 characters. The more characters in the password, the more 
combinations there are, making it more difficult to crack it.  For example, if a password only uses upper 
case letters, a four character password would have approximately 450,000 combinations, if it had six 
characters there would be approximately 310,000,000 combinations, and if you were to use 8 
characters, there would be approximately 210,000,000,000 combinations. 

2. Use a combination of numbers and letters and use a mix of upper and lower case letters. This also 
increases the number of combinations. For example, if a password only uses upper case letters, a four 
character password would have approximately 450,000 combinations, if it used both upper and lower 
case letters there would be approximately 7,000,000 combinations, and if numbers were included as 
well, then there would be approximately 15,000,000 combinations. 

3. Add a special character. This again increases the number of combinations, and reduces the risk of a 
dictionary attack. 

4. Change your password every few months. This way, if your password has been cracked it will 
eventually be changed. 

5. To create passwords that you can remember, use a phrase you can remember, and then take the first 
letter of each word, then append a number to it. For example, the phrase: This is a password phrase. 
could give you a password like Tiapp123. 

Don'ts

1. Don't write your passwords down, or store them unencrypted on your computer. 
2. Don't use a word or name that is personally associated with you, such as family member's name, birth 

month, city born in, etc. 
3. Don't use common words. These are easily cracked using a dictionary attack, where hackers will 

attempt to find your password by trying all words from a common list in a dictionary. 
4. Don't use the same password for all of your accounts and websites. If one of your passwords were to 

be cracked then the hacker would immediately know the password for all of your accounts and 
websites. 

PWMinder User Guide 72 of 83



 24.  Appendix 2 – Export

 24.1.XML Export

The following is an example of an xml export in grouped mode, showing passwords in plain text:

<?xml version="1.0" encoding="UTF-8"?>
<REPOSITORY version="2.0" name="Demo" description="A demo repository for display" filename="Demo.pwm"
created="2009-02-13 09:59:29 PST" exported="2009-07-20 13:44:45 PDT">
  <CATEGORIES>
    <CATEGORY>
      <NAME>Alarm System</NAME>
      <DESCRIPTION>Passcodes for alarm systems.</DESCRIPTION>
      <RECORDS>
        <RECORD>
          <NAME>home</NAME>
          <DESCRIPTION>Home alarm system</DESCRIPTION>
          <LOGIN>abc</LOGIN>
          <PASSWORD>345</PASSWORD>
          <ACCOUNT_NUMBER>fadtt</ACCOUNT_NUMBER>
          <NOTES />
          <URL>http://www.alarm.com</URL>
          <EMAIL />
          <SECURITY_QUESTION />
          <SECURITY_QUESTION_ANSWER />
          <EXPIRY>September 1, 2009</EXPIRY>
        </RECORD>
        <RECORD>
          <NAME>Office</NAME>
          <DESCRIPTION>Office alarm</DESCRIPTION>
          <LOGIN>xyz</LOGIN>
          <PASSWORD>987</PASSWORD>
          <ACCOUNT_NUMBER>123-985</ACCOUNT_NUMBER>
          <NOTES />
          <URL>http://www.alarm.com</URL>
          <EMAIL />
          <SECURITY_QUESTION />
          <SECURITY_QUESTION_ANSWER />
          <EXPIRY>No Expiry</EXPIRY>
        </RECORD>
      </RECORDS>
    </CATEGORY>
    <CATEGORY>
      <NAME>Bank Account</NAME>
      <DESCRIPTION>Passwords for Bank Accounts.</DESCRIPTION>
      <RECORDS>
        <RECORD>
          <NAME>Chequing</NAME>
          <DESCRIPTION>Chequing Account</DESCRIPTION>
          <LOGIN>user</LOGIN>
          <PASSWORD>pw</PASSWORD>
          <ACCOUNT_NUMBER>123-1234-123</ACCOUNT_NUMBER>
          <NOTES />
          <URL />
          <EMAIL />
          <SECURITY_QUESTION />
          <SECURITY_QUESTION_ANSWER />
          <EXPIRY>No Expiry</EXPIRY>
        </RECORD>
        <RECORD>
          <NAME>Savings</NAME>
          <DESCRIPTION>Savings Account.</DESCRIPTION>
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          <LOGIN>abc</LOGIN>
          <PASSWORD>123</PASSWORD>
          <ACCOUNT_NUMBER>987</ACCOUNT_NUMBER>
          <NOTES />
          <URL>http://www.bank.com</URL>
          <EMAIL>my@domain.com</EMAIL>
          <SECURITY_QUESTION>What is your favourite colour?</SECURITY_QUESTION>
          <SECURITY_QUESTION_ANSWER>Black</SECURITY_QUESTION_ANSWER>
          <EXPIRY>March 26, 2009</EXPIRY>
        </RECORD>
      </RECORDS>
    </CATEGORY>
    <CATEGORY>
      <NAME>Bank Web Sites</NAME>
      <DESCRIPTION>Banking Web Sites.</DESCRIPTION>
      <RECORDS>
        <RECORD>
          <NAME>BigBank</NAME>
          <DESCRIPTION>Bank site</DESCRIPTION>
          <LOGIN>user</LOGIN>
          <PASSWORD>Nbt48_7C</PASSWORD>
          <ACCOUNT_NUMBER />
          <NOTES />
          <URL>http://www.bigBank.com</URL>
          <EMAIL />
          <SECURITY_QUESTION />
          <SECURITY_QUESTION_ANSWER />
          <EXPIRY>No Expiry</EXPIRY>
        </RECORD>
      </RECORDS>
    </CATEGORY>
    <CATEGORY>
      <NAME>Cell Phone</NAME>
      <DESCRIPTION>Cell phone PIN</DESCRIPTION>
      <RECORDS />
    </CATEGORY>
    <CATEGORY>
      <NAME>Computer Account</NAME>
      <DESCRIPTION>Passwords used to log in to computers or networks.</DESCRIPTION>
      <RECORDS>
        <RECORD>
          <NAME>Linux</NAME>
          <DESCRIPTION>My Linux account</DESCRIPTION>
          <LOGIN>tux</LOGIN>
          <PASSWORD>penguin</PASSWORD>
          <ACCOUNT_NUMBER />
          <NOTES />
          <URL />
          <EMAIL />
          <SECURITY_QUESTION />
          <SECURITY_QUESTION_ANSWER />
          <EXPIRY>July 1, 2009</EXPIRY>
        </RECORD>
        <RECORD>
          <NAME>Windows Vista</NAME>
          <DESCRIPTION>Login for Windows Vista account</DESCRIPTION>
          <LOGIN>jdoe</LOGIN>
          <PASSWORD>password</PASSWORD>
          <ACCOUNT_NUMBER />
          <NOTES />
          <URL />
          <EMAIL />
          <SECURITY_QUESTION />
          <SECURITY_QUESTION_ANSWER />
          <EXPIRY>July 1, 2009</EXPIRY>
        </RECORD>
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        <RECORD>
          <NAME>Windows XP</NAME>
          <DESCRIPTION>My Windows XP Account</DESCRIPTION>
          <LOGIN>user</LOGIN>
          <PASSWORD>pw</PASSWORD>
          <ACCOUNT_NUMBER />
          <NOTES />
          <URL />
          <EMAIL />
          <SECURITY_QUESTION />
          <SECURITY_QUESTION_ANSWER />
          <EXPIRY>July 1, 2009</EXPIRY>
        </RECORD>
      </RECORDS>
    </CATEGORY>
    <CATEGORY>
      <NAME>Credit Card</NAME>
      <DESCRIPTION>Credit Card information</DESCRIPTION>
      <RECORDS />
    </CATEGORY>
    <CATEGORY>
      <NAME>Email Account</NAME>
      <DESCRIPTION>Passwords for email accounts.</DESCRIPTION>
      <RECORDS>
        <RECORD>
          <NAME>gmail</NAME>
          <DESCRIPTION>My gmail account</DESCRIPTION>
          <LOGIN>user@gmail.com</LOGIN>
          <PASSWORD>12345</PASSWORD>
          <ACCOUNT_NUMBER />
          <NOTES />
          <URL>http://www.gmail.com</URL>
          <EMAIL>user@gmail.com</EMAIL>
          <SECURITY_QUESTION />
          <SECURITY_QUESTION_ANSWER />
          <EXPIRY>No Expiry</EXPIRY>
        </RECORD>
        <RECORD>
          <NAME>hotmail</NAME>
          <DESCRIPTION>hotmail account</DESCRIPTION>
          <LOGIN>me@hotmail.com</LOGIN>
          <PASSWORD>_Fe459eu</PASSWORD>
          <ACCOUNT_NUMBER />
          <NOTES />
          <URL />
          <EMAIL />
          <SECURITY_QUESTION />
          <SECURITY_QUESTION_ANSWER />
          <EXPIRY>No Expiry</EXPIRY>
        </RECORD>
        <RECORD>
          <NAME>Shaw</NAME>
          <DESCRIPTION>Shaw webmail</DESCRIPTION>
          <LOGIN>vtewert</LOGIN>
          <PASSWORD>squeah89</PASSWORD>
          <ACCOUNT_NUMBER />
          <NOTES />
          <URL>https://webmail.shaw.ca/</URL>
          <EMAIL />
          <SECURITY_QUESTION />
          <SECURITY_QUESTION_ANSWER />
          <EXPIRY>No Expiry</EXPIRY>
        </RECORD>
      </RECORDS>
    </CATEGORY>
    <CATEGORY>
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      <NAME>Misc</NAME>
      <DESCRIPTION>Miscellaneous logins and passwords.</DESCRIPTION>
      <RECORDS>
        <RECORD>
          <NAME>other</NAME>
          <DESCRIPTION />
          <LOGIN>login</LOGIN>
          <PASSWORD>password</PASSWORD>
          <ACCOUNT_NUMBER />
          <NOTES>Added multiline notes</NOTES>
          <URL />
          <EMAIL />
          <SECURITY_QUESTION />
          <SECURITY_QUESTION_ANSWER />
          <EXPIRY>No Expiry</EXPIRY>
        </RECORD>
      </RECORDS>
    </CATEGORY>
    <CATEGORY>
      <NAME>Software Account</NAME>
      <DESCRIPTION>Passwords used to log in to software applications.</DESCRIPTION>
      <RECORDS>
        <RECORD>
          <NAME>PWMinder</NAME>
          <DESCRIPTION>PWMinder software</DESCRIPTION>
          <LOGIN>none</LOGIN>
          <PASSWORD>none</PASSWORD>
          <ACCOUNT_NUMBER />
          <NOTES />
          <URL />
          <EMAIL />
          <SECURITY_QUESTION />
          <SECURITY_QUESTION_ANSWER />
          <EXPIRY>No Expiry</EXPIRY>
        </RECORD>
      </RECORDS>
    </CATEGORY>
    <CATEGORY>
      <NAME>Web Site</NAME>
      <DESCRIPTION>Passwords used to log in to web sites.</DESCRIPTION>
      <RECORDS>
        <RECORD>
          <NAME>Ewert-Technologies</NAME>
          <DESCRIPTION>Ewert Technologies home page.</DESCRIPTION>
          <LOGIN>abc</LOGIN>
          <PASSWORD>123</PASSWORD>
          <ACCOUNT_NUMBER />
          <NOTES />
          <URL>http://www.ewert-technologies.ca</URL>
          <EMAIL>info@ewert-technologies.ca</EMAIL>
          <SECURITY_QUESTION />
          <SECURITY_QUESTION_ANSWER />
          <EXPIRY>February 12, 2010</EXPIRY>
        </RECORD>
        <RECORD>
          <NAME>yahoo.com</NAME>
          <DESCRIPTION>Yahoo.com user</DESCRIPTION>
          <LOGIN>me@yahoo.com</LOGIN>
          <PASSWORD>password</PASSWORD>
          <ACCOUNT_NUMBER />
          <NOTES />
          <URL>http://www.yahoo.com</URL>
          <EMAIL>me@yahoo.com</EMAIL>
          <SECURITY_QUESTION>What is your favourite colour?</SECURITY_QUESTION>
          <SECURITY_QUESTION_ANSWER>Blue</SECURITY_QUESTION_ANSWER>
          <EXPIRY>No Expiry</EXPIRY>
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        </RECORD>
      </RECORDS>
    </CATEGORY>
  </CATEGORIES>
</REPOSITORY>

The following is an example of an xml export in non-grouped mode:

<?xml version="1.0" encoding="UTF-8"?>
<REPOSITORY version="2.0" name="Demo" description="A demo repository for display" filename="Demo.pwm"
created="2009-02-13 09:59:29 PST" exported="2009-07-20 13:41:48 PDT">
  <RECORDS>
    <RECORD>
      <CATEGORY_NAME>Bank Web Sites</CATEGORY_NAME>
      <CATEGORY_DESCRIPTION>Banking Web Sites.</CATEGORY_DESCRIPTION>
      <NAME>BigBank</NAME>
      <DESCRIPTION>Bank site</DESCRIPTION>
      <LOGIN>user</LOGIN>
      <PASSWORD>**********</PASSWORD>
      <ACCOUNT_NUMBER />
      <NOTES />
      <URL>http://www.bigBank.com</URL>
      <EMAIL />
      <SECURITY_QUESTION />
      <SECURITY_QUESTION_ANSWER />
      <EXPIRY>No Expiry</EXPIRY>
    </RECORD>
    <RECORD>
      <CATEGORY_NAME>Bank Account</CATEGORY_NAME>
      <CATEGORY_DESCRIPTION>Passwords for Bank Accounts.</CATEGORY_DESCRIPTION>
      <NAME>Chequing</NAME>
      <DESCRIPTION>Chequing Account</DESCRIPTION>
      <LOGIN>user</LOGIN>
      <PASSWORD>**********</PASSWORD>
      <ACCOUNT_NUMBER>123-1234-123</ACCOUNT_NUMBER>
      <NOTES />
      <URL />
      <EMAIL />
      <SECURITY_QUESTION />
      <SECURITY_QUESTION_ANSWER />
      <EXPIRY>No Expiry</EXPIRY>
    </RECORD>
    <RECORD>
      <CATEGORY_NAME>Web Site</CATEGORY_NAME>
      <CATEGORY_DESCRIPTION>Passwords used to log in to web sites.</CATEGORY_DESCRIPTION>
      <NAME>Ewert-Technologies</NAME>
      <DESCRIPTION>Ewert Technologies home page.</DESCRIPTION>
      <LOGIN>abc</LOGIN>
      <PASSWORD>**********</PASSWORD>
      <ACCOUNT_NUMBER />
      <NOTES />
      <URL>http://www.ewert-technologies.ca</URL>
      <EMAIL>info@ewert-technologies.ca</EMAIL>
      <SECURITY_QUESTION />
      <SECURITY_QUESTION_ANSWER />
      <EXPIRY>February 12, 2010</EXPIRY>
    </RECORD>
    <RECORD>
      <CATEGORY_NAME>Email Account</CATEGORY_NAME>
      <CATEGORY_DESCRIPTION>Passwords for email accounts.</CATEGORY_DESCRIPTION>
      <NAME>gmail</NAME>
      <DESCRIPTION>My gmail account</DESCRIPTION>
      <LOGIN>user@gmail.com</LOGIN>

PWMinder User Guide 77 of 83



      <PASSWORD>**********</PASSWORD>
      <ACCOUNT_NUMBER />
      <NOTES />
      <URL>http://www.gmail.com</URL>
      <EMAIL>user@gmail.com</EMAIL>
      <SECURITY_QUESTION />
      <SECURITY_QUESTION_ANSWER />
      <EXPIRY>No Expiry</EXPIRY>
    </RECORD>
    <RECORD>
      <CATEGORY_NAME>Alarm System</CATEGORY_NAME>
      <CATEGORY_DESCRIPTION>Passcodes for alarm systems.</CATEGORY_DESCRIPTION>
      <NAME>home</NAME>
      <DESCRIPTION>Home alarm system</DESCRIPTION>
      <LOGIN>abc</LOGIN>
      <PASSWORD>**********</PASSWORD>
      <ACCOUNT_NUMBER>fadtt</ACCOUNT_NUMBER>
      <NOTES />
      <URL>http://www.alarm.com</URL>
      <EMAIL />
      <SECURITY_QUESTION />
      <SECURITY_QUESTION_ANSWER />
      <EXPIRY>September 1, 2009</EXPIRY>
    </RECORD>
    <RECORD>
      <CATEGORY_NAME>Email Account</CATEGORY_NAME>
      <CATEGORY_DESCRIPTION>Passwords for email accounts.</CATEGORY_DESCRIPTION>
      <NAME>hotmail</NAME>
      <DESCRIPTION>hotmail account</DESCRIPTION>
      <LOGIN>me@hotmail.com</LOGIN>
      <PASSWORD>**********</PASSWORD>
      <ACCOUNT_NUMBER />
      <NOTES />
      <URL />
      <EMAIL />
      <SECURITY_QUESTION />
      <SECURITY_QUESTION_ANSWER />
      <EXPIRY>No Expiry</EXPIRY>
    </RECORD>
    <RECORD>
      <CATEGORY_NAME>Computer Account</CATEGORY_NAME>
      <CATEGORY_DESCRIPTION>Passwords used to log in to computers or networks.</CATEGORY_DESCRIPTION>
      <NAME>Linux</NAME>
      <DESCRIPTION>My Linux account</DESCRIPTION>
      <LOGIN>tux</LOGIN>
      <PASSWORD>**********</PASSWORD>
      <ACCOUNT_NUMBER />
      <NOTES />
      <URL />
      <EMAIL />
      <SECURITY_QUESTION />
      <SECURITY_QUESTION_ANSWER />
      <EXPIRY>July 1, 2009</EXPIRY>
    </RECORD>
    <RECORD>
      <CATEGORY_NAME>Alarm System</CATEGORY_NAME>
      <CATEGORY_DESCRIPTION>Passcodes for alarm systems.</CATEGORY_DESCRIPTION>
      <NAME>Office</NAME>
      <DESCRIPTION>Office alarm</DESCRIPTION>
      <LOGIN>xyz</LOGIN>
      <PASSWORD>**********</PASSWORD>
      <ACCOUNT_NUMBER>123-985</ACCOUNT_NUMBER>
      <NOTES />
      <URL>http://www.alarm.com</URL>
      <EMAIL />
      <SECURITY_QUESTION />
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      <SECURITY_QUESTION_ANSWER />
      <EXPIRY>No Expiry</EXPIRY>
    </RECORD>
    <RECORD>
      <CATEGORY_NAME>Misc</CATEGORY_NAME>
      <CATEGORY_DESCRIPTION>Miscellaneous logins and passwords.</CATEGORY_DESCRIPTION>
      <NAME>other</NAME>
      <DESCRIPTION />
      <LOGIN>login</LOGIN>
      <PASSWORD>**********</PASSWORD>
      <ACCOUNT_NUMBER />
      <NOTES>Added multiline notes</NOTES>
      <URL />
      <EMAIL />
      <SECURITY_QUESTION />
      <SECURITY_QUESTION_ANSWER />
      <EXPIRY>No Expiry</EXPIRY>
    </RECORD>
    <RECORD>
      <CATEGORY_NAME>Software Account</CATEGORY_NAME>
      <CATEGORY_DESCRIPTION>Passwords used to log in to software applications.</CATEGORY_DESCRIPTION>
      <NAME>PWMinder</NAME>
      <DESCRIPTION>PWMinder software</DESCRIPTION>
      <LOGIN>none</LOGIN>
      <PASSWORD>**********</PASSWORD>
      <ACCOUNT_NUMBER />
      <NOTES />
      <URL />
      <EMAIL />
      <SECURITY_QUESTION />
      <SECURITY_QUESTION_ANSWER />
      <EXPIRY>No Expiry</EXPIRY>
    </RECORD>
    <RECORD>
      <CATEGORY_NAME>Bank Account</CATEGORY_NAME>
      <CATEGORY_DESCRIPTION>Passwords for Bank Accounts.</CATEGORY_DESCRIPTION>
      <NAME>Savings</NAME>
      <DESCRIPTION>Savings Account.</DESCRIPTION>
      <LOGIN>abc</LOGIN>
      <PASSWORD>**********</PASSWORD>
      <ACCOUNT_NUMBER>987</ACCOUNT_NUMBER>
      <NOTES />
      <URL>http://www.bank.com</URL>
      <EMAIL>my@domain.com</EMAIL>
      <SECURITY_QUESTION>What is your favourite colour?</SECURITY_QUESTION>
      <SECURITY_QUESTION_ANSWER>Black</SECURITY_QUESTION_ANSWER>
      <EXPIRY>March 26, 2009</EXPIRY>
    </RECORD>
    <RECORD>
      <CATEGORY_NAME>Email Account</CATEGORY_NAME>
      <CATEGORY_DESCRIPTION>Passwords for email accounts.</CATEGORY_DESCRIPTION>
      <NAME>Shaw</NAME>
      <DESCRIPTION>Shaw webmail</DESCRIPTION>
      <LOGIN>vtewert</LOGIN>
      <PASSWORD>**********</PASSWORD>
      <ACCOUNT_NUMBER />
      <NOTES />
      <URL>https://webmail.shaw.ca/</URL>
      <EMAIL />
      <SECURITY_QUESTION />
      <SECURITY_QUESTION_ANSWER />
      <EXPIRY>No Expiry</EXPIRY>
    </RECORD>
    <RECORD>
      <CATEGORY_NAME>Computer Account</CATEGORY_NAME>
      <CATEGORY_DESCRIPTION>Passwords used to log in to computers or networks.</CATEGORY_DESCRIPTION>
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      <NAME>Windows Vista</NAME>
      <DESCRIPTION>Login for Windows Vista account</DESCRIPTION>
      <LOGIN>jdoe</LOGIN>
      <PASSWORD>**********</PASSWORD>
      <ACCOUNT_NUMBER />
      <NOTES />
      <URL />
      <EMAIL />
      <SECURITY_QUESTION />
      <SECURITY_QUESTION_ANSWER />
      <EXPIRY>July 1, 2009</EXPIRY>
    </RECORD>
    <RECORD>
      <CATEGORY_NAME>Computer Account</CATEGORY_NAME>
      <CATEGORY_DESCRIPTION>Passwords used to log in to computers or networks.</CATEGORY_DESCRIPTION>
      <NAME>Windows XP</NAME>
      <DESCRIPTION>My Windows XP Account</DESCRIPTION>
      <LOGIN>user</LOGIN>
      <PASSWORD>**********</PASSWORD>
      <ACCOUNT_NUMBER />
      <NOTES />
      <URL />
      <EMAIL />
      <SECURITY_QUESTION />
      <SECURITY_QUESTION_ANSWER />
      <EXPIRY>July 1, 2009</EXPIRY>
    </RECORD>
    <RECORD>
      <CATEGORY_NAME>Web Site</CATEGORY_NAME>
      <CATEGORY_DESCRIPTION>Passwords used to log in to web sites.</CATEGORY_DESCRIPTION>
      <NAME>yahoo.com</NAME>
      <DESCRIPTION>Yahoo.com user</DESCRIPTION>
      <LOGIN>me@yahoo.com</LOGIN>
      <PASSWORD>**********</PASSWORD>
      <ACCOUNT_NUMBER />
      <NOTES />
      <URL>http://www.yahoo.com</URL>
      <EMAIL>me@yahoo.com</EMAIL>
      <SECURITY_QUESTION>What is your favourite colour?</SECURITY_QUESTION>
      <SECURITY_QUESTION_ANSWER>Blue</SECURITY_QUESTION_ANSWER>
      <EXPIRY>No Expiry</EXPIRY>
    </RECORD>
  </RECORDS>
</REPOSITORY>
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 25.  Appendix 4 - License Agreement

The PWMinder License Agree can be found in <Install Directory>/PWMinder/docs/license.txt

It is also reproduced here:
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SOFTWARE EVALUATION LICENSE
BY USING THIS SOFTWARE, YOU AGREE TO THE FOLLOWING TERMS AND CONDITIONS:

The version of PWMinder you are installing is trialware. You are hereby granted a 
license to use this software for a period of 30 days. After that time, you are 
required to activate this software and pay the applicable fee, or else discontinue 
using it.  An Activation Code may be used on up to two computers within the same 
household, for example the same Activation Code may be used on your Desktop 
Computer and Laptop.

You are allowed to make copies of this program and distribute it to third parties, 
provided this software is not distributed for profit. If you distribute this 
program, you agree to distribute this license, along with this software. You are 
not allowed to distribute your Activation Code to others, outside of your 
household.  You are not allowed to bundle this program with other products without 
prior written permission from Ewert Technologies (info@ewert-technologies.ca).

1.  Ownership of Software
As licensee, you own the media upon which this software is recorded or distributed 
and are entitled to use this software, but all rights in, title to and ownership of
the original software and all subsequent copies shall be retained solely by Ewert 
Technologies (www.ewert-technologies.ca). The granting of this license does not 
constitute a sale of this software or any copy thereof. You are not allowed to make
any modifications to, or to create derivative works from any of the files that are 
used in or that accompany this software.

2.  Limited Warranty
This software is provided "as is" without warranty of any kind, either expressed or
implied, but not limited to, the implied warranties or conditions of 
merchantability and fitness for a particular purpose. The user must assume the 
entire risk as to the quality and performance of this software. Should this 
software prove defective, the user assumes the entire cost of all necessary 
servicing, repair, or correction. Any liability of the seller will be limited 
exclusively to product replacement or refund of purchase price. This warranty gives
you specific legal rights and you may also have other rights which vary from 
jurisdiction to jurisdiction.

3.  Limitation of Liability
In no event shall Ewert Technologies or any of its authorized dealers or suppliers 
be liable to you or any other party for any damages whatsoever (including, without 
limitation, damages for loss of business profits, business interruption, loss of 
business information, or other incidental or consequential damages) arising out of 
the use of or inability to use this software, even if Ewert Technologies has been 
advised of the possibility of such damages. Some jurisdictions do not allow the 
limitation or exclusion of liability for incidental or consequential damages so the
above limitation or exclusion may not apply to you.

While all attempts have been made to make the encrypted repository file as secure 
as possible, any encryption method can be broken, especially if the password is 
short and/or easily guessable.  Please ensure that the password(s) for your 
repository(ies) is/are at least 10 characters long, and contains upper case and/or 
lower case characters, and/or numbers.  Ewert Technologies accepts no 
responsibility for repository files that get "hacked".
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In addition, ensure that the password(s) used for repositories are remembered, as 
there is no way to recover a forgotten password, and Ewert Technologies accepts no 
responsibility for repositories that can't be opened due to forgotten passwords.

4.  General
You acknowledge that you have read this agreement, understand it, and that by 
making any use of this software you agree to be bound by these terms and 
conditions. You further agree that this constitutes the entire agreement between 
you and Ewert Technologies, which supersedes any prior verbal or written agreement 
with respect to the matters set out herein. You understand and agree that you have 
no rights in or to the software except the license specifically granted in this 
agreement.

If you have any questions about this agreement, contact Ewert Technologies at 
info@ewert-technologies.ca.
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